PopcornFX v2.13

Generic selectors
Exact matches only
Search in title
Search in content
Post Type Selectors
  1. Home
  2. Docs
  3. PopcornFX v2.13
  4. Plugins
  5. Unreal Engine plugin

Unreal Engine plugin

Overview

This section will cover how to install and use the Unreal Engine plugin for PopcornFX v2.

Plugin versions

For each PopcornFX SDK/Editor release, there is a matching Unreal Engine plugin:

When updating your PopcornFX Editor, make sure to also update the Unreal Engine plugin to match that editor version.

Unreal Engine versions

When a new UE version comes out, we provide a plugin update.

The latest plugin currently supports: UE4.26, UE4.27 and UE5.0

Note: In v2.12, the UE5.0 support is experimental for Win64, feel free to reach out to us on our discord if you need any help.

This plugin does

  • Ultimately implement all the PopcornFX SDK integration features
  • Use the standard pipelines of Unreal Engine 4 and 5 for workflow, rendering etc… (if we do something wrong, please contact us!)
  • Let you customize particle materials for rendering
  • Keep the plugin a plugin: no engine source code modification needed !

This plugin does not

  • Provide a way to author PopcornFX v2 effects directly inside the UE4/UE5 editor. To do this, you have to use the PopcornFX v2 Editor
  • Have a relation with Unreal Engine’s Cascade or Niagara particle systems, PopcornFX is another, different particle system engine

 

Articles

Was this article helpful to you? Yes No

How can we help?